RIP (Routing Information Protocol) - IOS

Function: 
Summary
  • RIP is an interdomain routing protocol that uses a distance vector approach to determine the paths between routers.
Detailed Description
  • RIP minimizes the number of hops of each path, where each point-to-point link or LAN constitutes a hop. Each RIP-enabled router will periodically send the content of its routing table to all its neighboring routers in an update message. For each routing table entry, the router sends the destination (host IP address or network IP address) and the distance to that destination measured in hops. When a router receives an update message from a neighboring router, it updates its own routing table.
Examples
  • Following is a brief overview of the basic commands used to configure RIP on a Cisco router.
Global Configuration:  
router rip Enables the routing protocol RIP on the local router and enters the router configuration mode.
no router rip Disables RIP on the local router.

show ip rip database, or show ip route rip

Displays the routing database of the RIP protocol.

Privileged Exec:  
debug ip rip Enables a debugging mode where the router displays a message for each received RIP packet.
no debug ip rip Disables the debugging feature.
Router Configuration:  
network Netaddr Associates the network IP address Netaddrwith RIP. RIP sends updates only on interfaces on which the network address has been associated with RIP.
no network Netaddr Disables RIP for the specified network address.
passive-interface Iface Sets the interface Iface in RIP passive mode. Passive mode means the router processes incoming RIP packets but does not transmit RIP packets.
no passive-interface Iface Enables active mode on interface Iface.This means that RIP packets are transmitted on this interface.
offset-list 0 in value Iface Increases the metric (hop count) of incoming RIP packets that arrive on interface Iface by value, where value is a number.
offset-list 0 out value Iface Increases the metric of outgoing RIP packets that are sent on interface Iface by value.
no offset-list 0 in value Iface Disables the specified offset-list command for incoming RIP packets.
no offset-list 0 out value Iface Disables the specified offset-list command for outgoing RIP packets.
redistribute connected Makes sure that the ripd process sends updates on its directly connected interfaces, Command not needed on routers.
version 2 Sets the RIP version to RIPv2.

 

timers basic update invalid hold-down flush
Sets the values of the timers in the RIP protocol.

  • update
The time interval between transmissions of RIP update messages (default: 30 seconds)

  • invalid
The time interval after which a route, which has not been updated, is declared invalid (default: 180 seconds).

  • hold-down
Determines how long after a route has been updated as unabailable a router will wait before accepting a new route with a lower metric. This introduces a delay for processing incoming RIP packets with routing updates after a link failure (default: 180 seconds).

  • flush
The amount of time that must pass before a route that has not been updated is removed from the routing table (default: 240 seconds).
Example: Router1 (config-router)# timers basic 30 180 180 240

 

flash-update-threshold time

Sets the router to not perform triggered updates, when the next transmission of routing updates is due in time. If time is set to the same value as the update timer, then triggered updates are disabled. In RIP, a triggered update means that a router sends a RIP packet with a routing update, whenever one of its routing table entries changes.
  • Configuring RIP on Cisco routers

Router1> enable

Password: <enable secret>

Router1# configure terminal

Router1(config)# no ip routing

Router1(config)# ip routing

Router1(config)# router rip

Router1(config-router)# version 2

Router1(config-router)# network 10.0.0.0

Router1(config-router)# interface Fa0/0

Router1(config-router)# no shutdown

Router1(config-router)# ip address 10.0.1.1 255.255.255.0

Router1(config-router)# interface Fa0/1

Router1(config-router)# no shutdown

Router1(config-router)# ip address 10.0.2.1 255.255.255.0

Router1(config-router)# end

Router1# clear ip route

  • Example configuration on Router2 for setting the hold-down timer to 0 and disabling triggered updates:

Router2> enable

Password: <enable secret>

Router2# configure terminal

Router2(config)# ip routing

Router2(config)# router rip

Router2(config-router)# version 2

Router2(config-router)# network 10.0.0.0

Router2(config-router)# timers basic 30 180 0 240

Router2(config-router)# flash-update-threshold 30

Router2(config-router)# end

Router2# clear ip route *

 

 

Links

Cisco RIP documentation (PDF)

PacketLife Cheat Sheets: RIP